Not signed in (Sign In)

Welcome, Guest

Want to take part? Sign in or apply for an account below

Vanilla 1.1.4 is a product of Lussumo. More Information: Documentation, Community Support.


    I just bought the software - and registered it . I want to compose a piece that is 180 seconds long . But the time line will not accept or play anything beyond 12 seconds - What do I do about this ?
    • CommentAuthoradmin
    • CommentTimeSep 21st 2011
    In the documention, you'll see how to do it:

    Simply enter 180 in the Piece duration box at the top of the score.
    I am running the software on a Macbook Pro, using 10.6.8 operating system, with a 2.93 Ghz intel core 2 duo
    processor, and 8 Gb 1067 Mhz DDR3 of memory. When I attempt to play a single sound, 33 seconds long, and
    tye 33 into the piece duration box, it plays about 17 seconds. I had the same problem as the person mentioned
    above, for another piece: i type 16, and then 24 sec, and it consistently play 12. I have tried a single sound
    source as a long sustained sound - it doesn't happen; same thing with several layered long sustained sounds,
    even using different base sounds from the noise section. As soon as the sounds start changing, and there are
    a lot of things happening in each layer, the program chokes near the end of specified duration. I tried adding
    a sustained long sound introduced in the complex ending - it chokes, creates silence, and then resumes and
    plays the last few seconds.

    I'll keep trying, and testing, but it seems something is haywire.
    • CommentAuthoradmin
    • CommentTimeJun 17th 2012
    Hello, can you send me or attach to your comment the piece whose duration you cannot set?

    Other than that, just a check: are you indeed pressing return after typing the piece duration, to validate the new duration?
    yes, i checked to make sure. i tried some more files, simplifed relationships, etc. Still losing the last second to three
    seconds on very complicated files. I'll attach one, and if you want more examples, I'll provide them.

    Just to make clear, the duration may be set - the problem is that the playback stops
    short of the end. The line keeps moving along the time line till the end duration, but
    the sound stops. I tried increasing the number of real time ossilators in the preferences,
    thinking I didn't have enough sound processing force, but that made no difference.


    ps. it seems the attachment does not like the extensive *.upic - i cannot tell if it aborted
    the upload or not.

    HB-Complex01f.upic was the file name. I'll try adding *.upic.doc to fake it
    out - then you can delete the .doc
    • CommentAuthoradmin
    • CommentTimeJun 17th 2012
    I found the culprit: the Butterworth noise band filter waveform, that you are using, apparently is buggy (as is the CrazyNoiseBand that you seem to be using a lot). Clearly, this waveform has trouble handling some audio frequencies and some shapes of sounds, and yields massive clipping in some specific configurations.

    You can fix your piece by getting rid of the sounds that use his waveform, or tweaking them till they render properly.

    As for fixing the bug: the drawback if I fix this problem is that other pieces that used this waveform many end up not sounding the same. In any case, I should fix the issue created by this waveform, retaining a compabitility mode.

    Thanks for your perseverance in reporting the problem. I hope to finding out the issue during this summer.
    ok, in this case the workaround is fine for me, as i was after timbral diversity,
    not the specific characteristics of the butterworth - i'll either avoid it and the
    crazies, or tweak until i get what i want.

    thanks for getting at this so quickly - it's very helpful.

    i got rid of all the butterworth filter instruments and crazy noise and
    chamberlin, too - it works perfectly now, so that we definitely the
    source of the timing difficulties.

    thanks again,